Talkback for article: 150, May2000

Building DHCP automatically

Back to: http://cgi.linuxfocus.org/English/May2000/article150.shtml

From: Eric Seigne <erics(at)rycks.com> [ date: 2000-05-07 ]
J'ai reçu par email la question suivante, ça me paraît important d'apporter la réponse ici ...

---

On Sun, May 07, 2000 at 12:01:54PM +0200, Amaury JACQUOT wrote:
>:Bonjour Eric.
>:J'ai lu avec interet ton article sur DHCP et Linux (ce qui m'aidera
>:a virer le dernier NT de ma boite, qui ne sert qu'a ca), mais j'ai
>:encore un probleme :
>:la machine sur laquelle j'ai l'intention d'installer DHCP est mon
>:routeur vers mon fournisseur d'acces. a cet effet, j'ai deux cartes
>:reseau, eth0 a laquelle est affectee une adresse IP par DHCP, et
>:eth1 qui est sur mon reseau interne (IP fixe, 172.16.0.1).
>:mon probleme est que je ne souhaite pas servir des adresses
>:sur eth0
>:Quelle est dans ce cas la configuration a ajouter aux exemples
>:de l'article ?
>:
>:Amicalement
>:
>:Amaury

Remarque très importante !
En effet, j'ai eu exactement ce problème lorsque j'ai laissé mon serveur dhcp
tourner quand j'ai débarqué sur le cable ... et j'ai "absorbé" quelques
abonnés de wanadoo ! oups pour l'upload :) désolé pour les victimes ...

Bon je cherche la manip exacte:

il faut donner un parametre à dhcpd ... donc, si ta une redhat like (et
dérivée), edite le fichier /etc/rc.d/init.d/dhcpd et sur la ligne
daemon /usr/sbin/dhcpd
il faut rajouter eth1 après:
daemon /usr/sbin/dhcpd eth1

Et ca marche impec apres :)

pour une débian (distrib que j'aime de plus en plus) il faut
dans le bloc de /etc/init.d/dhcp
start-stop-daemon --start --quiet --pidfile $DHCPDPID \
--exec /usr/sbin/dhcpd
rajouter eth1 après dhcpd
start-stop-daemon --start --quiet --pidfile $DHCPDPID \
--exec /usr/sbin/dhcpd eth1

Tout ca bien sur si le reseau local est sur eth1 tu m'a compris :)

A ton service, content que ma ptite doc te soir utile,
a+
rics
--
Eric Seigne
@home: erics@pantoufle.deep-ocean.org
@work: erics@rycks.com

From: Eric Seigne <erics(at)rycks.com> [ date: 2000-05-07 ]
Le script perl n'étant pas téléchargeable, utilisez l'url suivante pour l'obtenir:

http://www.rycks.com/erics/linux/dhcp-auto.pl.text

a+
rics
--
Eric Seigne
@home: erics@pantoufle.deep-ocean.org
@work: erics@rycks.com


From: Eric BERTHOMIER <eric.berthomier(at)free.fr> [ date: 2001-10-30 ]
Bonjour,

je viens de lire avec un grand intérêt votre article sur le DHCP et
j'aurai quelques questions techniques :

Voici la config. de mon réseau

ADSL
:
SmoothWall (Routeur DHCP Linux)
!
HUB
/ \
/ \
! !
Plage DHCP Plage Serveur
192.168.2. 16
128 -> 256 192.168.2.16
Nom de domaine privé : BI.COM
Serveur WINS actif mais services non démarrés

Le serveur DHCP a l'air de fonctionner correctement.

Lors du démarrage de session mon Win$, celui-ce doit se connecter au
serveur pour valider mon mot de passe et me permettre ainsi d'accéder à
ses données. Problème : la connexion est refusée alors que le ping
fonctionne.

Une idée ?

Merci d'avance
Eric BERTHOMIER
http://lesouriciergris.free.fr

From: aliel <lila190(at)caramail.com> [ date: 2002-12-11 ]
bonjour,
j'ai configuré un serveur dhcp et tout fonctionne à merveille seulement un jour il s'est arrêté , même aprés le redémarrage du service. j'ai constaté par la suite qu'un autre serveur dans mon réseau a pris la main. Sachant que j'ai deux cartes réseaux sur mon serveur et que eth1 est celle qu'utilise le sereur dhcp, eth0 a une adresse publique (un NAT permet de ramener les paquets entre les deux interfaces).
comment faire pour eviter cela ? car mon serveur dhcp est le serveur officiel du réseau .
From: Nicolas <laszlo(at)pacaterie.u-psud.fr> [ date: 2003-04-12 ]
Bonjour et bravo pour votre documentation, elle est très bien réalisé. :)

Avant tout, je suis sous Debian woody et mon interface est eth0.

Ceci étant dis, voici mon problème : lorsque je lance mon serveur DHCP, voici ce qu'il me répond :

No subnet declaration for start (0.0.0.0).
Please write a subnet declaration in your dhcpd.conf file for the network segment to which interface start is attached.
exiting.

qaund je lance mon dhcp via la commande suivante :

/user/sbien/dhcpd eth0

Il me répond :

No subnet declaration for start eth0 (0.0.0.0).
Please write a subnet declaration in your dhcpd.conf file for the network segment to which interface eth0 is attached.
exiting.

J'ai bien vérifié dans /etc/init.d/dhcp si mon interface était bien eth0 et elle l'est bien.

Merci d'avance pour votre aide.

Cordialement

From: mourad moustaadil <m_moustaadil(at)hotmail.com> [ date: 2003-05-06 ]
hi,
anyone can help me ? i have the following problem with dhcp, when i have installed dhcp-2.Op51...rpm , i don't find dhcpd.conf file, i wondered if i must do it manually.
thank you in advance

6 talkbacks in Francais
Other talkbacks:   English Nederlands Italiano Castellano




Due to the increased amount of web spam we have deciced to removed the talkback posting possibility. You can read old talkbacks but you can no longer post new ones.

Back to http://cgi.linuxfocus.org/English/May2000/article150.shtml

Please contact webmaster(at)linuxfocus.org if you have any questions with regards to this talkback

lftalkback version 3.10